A-10C The Enemy Within Campaign

Home > E-Shop > Campaigns > A-10C The Enemy Within Campaign
A-10C The Enemy Within Campaign

Requires DCS World version 1.5!

The Enemy Within is a story - driven campaign that puts you in cockpit of an A-10C Warthog, sent as a part of small US detachment to Georgia in order to help contain a growing threat from a terrorist organisation calling itself the "Caucasus Liberation Army" (CLA). As the story unfolds, you will be faced with a variety of challenges, including close air support, precision strikes, combat search and rescue, anti-ship strikes and even air to air combat. Striving to be as realistic as possible, the units featured in the campaign are based on their real-life counterparts. It also uses a sophisticated radio control system, meaning that you have to tune your on-board radios to the correct frequency to be able to hear more than 670 voiceovers included in the campaign. There are also over 80 pages on FRAGOs (fragmentary orders, based on the ones used by US Air Force), 50 pages of briefings and 40 maps and recon photos designed to help you successfully finish all the 21 missions.

The DCS: A-10C Warthog module is required to be installed and activated into the DCS World 1.5 for the campaign.

DRM key has 3 activations.

STEAM Incompatible

Requires another product

Minimum system requirements: OS 64-bit Windows 7/8/10; DirectX11; CPU: Core i3; RAM: 8 GB; Free hard disk space: 30 GB; Discrete video card: 2 GB RAM (AMD, NVIDIA); requires internet activation.

Recommended system requirements: OS 64-bit Windows 7/8/10; DirectX11; CPU: Core i5+; RAM: 16GB; Hard disk space: 30 GB; Video: NVIDIA GeForce GTX780 / ATI R9 290 DirectX11 or better; Joystick; requires internet activation.

This product can be downloaded and installed through the DCS World Module Manager. If you do not have DCS World installed, you can download the DCS World web-installer by clicking this link. If the product description does not have information about which DCS World version you should install, you only need to have the "Stable" version DCS World 1.5 installed on your PC.

Visa Visa Electron Visa Debit / Delta MasterCard American Express
FOLLOW US