I got tired of the ASP-17 sight's reflections, so I created this mod. IMPORTANT NOTE: This mod is not compatible with DCS Open Beta 2.5.6.47224 and above. Also, ED has finally fixed the HUD reflection problem, so if you're using DCS 2.5.6.47224 or above, this mod isn't ...
Date: 04/17/2020

Sorted by relevance | Sort by date

FOLLOW US